Lexar UHS-II SD Cards in D500

Updated

Why no comments yet about all the people claiming issues with Lexar UHS-II cards in the D500? Because I don’t know for sure if the problem is a card problem or a camera problem. It could be either or both.

Here’s what we do know after a week:

The clue is when the error occurs: image review. You occasionally get a “This memory card cannot be used. Card may be damaged. Insert another card” message at some point when you try to do image review (which could include during shooting if you’ve got Image Review set to On). 

The only reports of this failure so far are with 1000x and 2000x Lexar UHS-II cards. These are cards that Nikon lists as compatible in the D500 manual, and will say they support via Nikon customer service. I know of no reports with any other brand of cards, or even with Lexar cards that are only UHS-I. 

Cards that report this error on a D500 seem to do fine if you shut the camera down and turn it back on. At least for awhile. Then the error repeats. The error does not happen when you take that card and put it in another Nikon DSLR (or other camera that I’ve tried).

The fact that the error happens on image review makes me strongly suspect signal timing or power draw or both. And that could be either a Lexar problem or a Nikon problem. (Originally I wrote: "That we don’t see this on other cameras would tend to implicate Nikon, not Lexar.” That appears to no longer be true. I’ve gotten anecdotal, but unverified reports of Lexar cards showing the same problem on other cameras, and someone reminded me that this is very similar to the Lexar CompactFlash problem had with the D4.)  Note that examination of a card Nikon reports as “damaged” shows that it is not damaged. What seems to be happening is that the camera is not seeing the allocation tables and/or directory correctly when image review is invoked. But not all the time. 

I suppose it is possible this is a power related issue, as turning the LCD on is a big power draw event, and trying to read from the card simultaneously is more power draw, though I doubt that at the moment. 

I have no idea what Nikon was trying to accomplish with their battery level tweaks, but it has had side implications, even for Nikon batteries. I’ve now had a report that a Nikon Li-Ion1 battery failed in a D500, and plenty of reports of Li-Ion1 batteries displaying different battery information in a D500 than in other Nikon DSLRs. At this point I wouldn’t be surprised to see issues with the MB-D17 grip and older EN-EL15 batteries. My grip is still not here yet, so I can’t check it’s power reporting yet.  

Whatever the cause, Nikon yet again has at least one significant launch issue with a DSLR. Let’s hope that we get a response from Nikon and/or Lexar about this sooner rather than later. Once again the Nikon brand reputation is on the line, and this time with pretty much the core of their DSLR loyalists.  

The real issue with all of these Nikon problems seems to be the same: lack of time in true beta testing. The issues that are getting reported almost certainly would have come up in a true beta test, as they’re not subtle or hidden issues. So I guess the question is this: would you rather have Nikon withhold products from the market longer to do a pretty full beta test, or do you prefer the release-and-fix scenario we seem to be getting?

Update: Nikon released firmware 1.02 to deal with this problem.

text and images © 2020 Thom Hogan
portions Copyright 1999-2019 Thom Hogan-- All Rights Reserved
Follow us on Twitter@bythom, hashtags #bythom, #dslrbodies